summaryrefslogtreecommitdiffstats
path: root/xlators/features/trash/src/Makefile.am
diff options
context:
space:
mode:
authorAmar Tumballi <amar@gluster.com>2009-11-30 01:16:35 +0000
committerAnand V. Avati <avati@dev.gluster.com>2009-12-01 10:02:48 -0800
commit936001b147a3adcf9731d02e8f2fb62e5e50caf4 (patch)
treeed0592d8276a3ff16ec3e15e58c4819b33352992 /xlators/features/trash/src/Makefile.am
parent90cebe19380b4319e3a4345f31268563b51e08c3 (diff)
features/trash initial cleanup commit
* support O_TRUNC flag in open (call comes to FS as 'truncate' or 'ftruncate' fop) * option to provide 'eliminate-pattern' so those files matching won't be kept in trash. Eg: option eliminate-pattern *.out|*~ * option to give 'maximum' file size to keep in trash, ie, when a 20GB file is deleted, it won't be kept in trash if max file size given is 1GB. Eg: option max-trashable-file-size 1GB These particular features are developped as a part of college project by following team: Sunil bhagwath <sunilkbhagwat@gmail.com> Yashaswi Kumar <yashaswikumar@gmail.com> Rashmi B K <rashmibk17@gmail.com> Sandeep M <astrophyster@gmail.com> Submitting after minor coding standard edits and memoryleak fixes. Signed-off-by: Amar Tumballi <amar@gluster.com> Signed-off-by: Anand V. Avati <avati@dev.gluster.com> BUG: 142 (enhance features/trash translator so it can work on client side too..) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=142
Diffstat (limited to 'xlators/features/trash/src/Makefile.am')
-rw-r--r--xlators/features/trash/src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/xlators/features/trash/src/Makefile.am b/xlators/features/trash/src/Makefile.am
index 52fced524..15998a56e 100644
--- a/xlators/features/trash/src/Makefile.am
+++ b/xlators/features/trash/src/Makefile.am
@@ -6,6 +6,8 @@ trash_la_LDFLAGS = -module -avoidversion
trash_la_SOURCES = trash.c
trash_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+noinst_HEADERS = trash.h
+
AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS)\
-I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS)