summaryrefslogtreecommitdiffstats
path: root/libglusterfs/src/gfdb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libglusterfs/src/gfdb/Makefile.am')
-rw-r--r--libglusterfs/src/gfdb/Makefile.am24
1 files changed, 14 insertions, 10 deletions
diff --git a/libglusterfs/src/gfdb/Makefile.am b/libglusterfs/src/gfdb/Makefile.am
index 50cf3402787..3931e694c24 100644
--- a/libglusterfs/src/gfdb/Makefile.am
+++ b/libglusterfs/src/gfdb/Makefile.am
@@ -1,12 +1,14 @@
libgfdb_la_CFLAGS = -Wall $(GF_CFLAGS) $(GF_DARWIN_LIBGLUSTERFS_CFLAGS) \
- $(SQLITE_CFLAGS) -DDATADIR=\"$(localstatedir)\"
+ $(SQLITE_CFLAGS) -DDATADIR=\"$(localstatedir)\"
libgfdb_la_CPPFLAGS = $(GF_CPPFLAGS) -D__USE_FILE_OFFSET64 -fpic \
- -I$(top_srcdir)/libglusterfs/src \
- -DDATADIR=\"$(localstatedir)\"
+ -I$(top_srcdir)/libglusterfs/src \
+ -I$(top_srcdir)/rpc/xdr/src \
+ -I$(top_builddir)/rpc/xdr/src \
+ -DDATADIR=\"$(localstatedir)\"
libgfdb_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
- $(SQLITE_LIBS) $(UUID_LIBS)
+ $(SQLITE_LIBS) $(UUID_LIBS)
libgfdb_la_LDFLAGS = $(GF_LDFLAGS) -version-info $(LIBGLUSTERFS_LT_VERSION)
@@ -18,14 +20,16 @@ endif
CONTRIB_BUILDDIR = $(top_builddir)/contrib
-libgfdb_la_SOURCES = gfdb_data_store.c gfdb_data_store_helper.c gfdb_sqlite3_helper.c\
- gfdb_sqlite3.c
+libgfdb_la_SOURCES = gfdb_data_store.c gfdb_data_store_helper.c \
+ gfdb_sqlite3_helper.c gfdb_sqlite3.c
-noinst_HEADERS = gfdb_data_store.h gfdb_data_store_types.h gfdb_sqlite3_helper.h\
- gfdb_sqlite3.h gfdb_mem-types.h gfdb_data_store_helper.h
+noinst_HEADERS = gfdb_data_store.h gfdb_data_store_types.h \
+ gfdb_sqlite3_helper.h gfdb_sqlite3.h gfdb_mem-types.h \
+ gfdb_data_store_helper.h
-libgfdb_HEADERS = gfdb_data_store.h gfdb_data_store_types.h gfdb_data_store_helper.h\
- gfdb_sqlite3.h gfdb_mem-types.h gfdb_sqlite3_helper.h
+libgfdb_HEADERS = gfdb_data_store.h gfdb_data_store_types.h \
+ gfdb_data_store_helper.h gfdb_sqlite3.h gfdb_mem-types.h \
+ gfdb_sqlite3_helper.h
CLEANFILES =