summaryrefslogtreecommitdiffstats
path: root/tools/setgfid2path/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/setgfid2path/src/Makefile.am')
-rw-r--r--tools/setgfid2path/src/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/setgfid2path/src/Makefile.am b/tools/setgfid2path/src/Makefile.am
new file mode 100644
index 00000000000..45520cadafb
--- /dev/null
+++ b/tools/setgfid2path/src/Makefile.am
@@ -0,0 +1,14 @@
+gluster_setgfid2pathdir = $(sbindir)
+
+gluster_setgfid2path_PROGRAMS = gluster-setgfid2path
+
+gluster_setgfid2path_SOURCES = main.c
+
+gluster_setgfid2path_LDADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+gluster_setgfid2path_LDFLAGS = $(GF_LDFLAGS)
+
+AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
+ -I$(top_builddir)/rpc/xdr/src
+
+AM_CFLAGS = -Wall $(GF_CFLAGS)