summaryrefslogtreecommitdiffstats
path: root/xlators/features/changetimerecorder/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/features/changetimerecorder/src/Makefile.am')
-rw-r--r--xlators/features/changetimerecorder/src/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/xlators/features/changetimerecorder/src/Makefile.am b/xlators/features/changetimerecorder/src/Makefile.am
index 503c6db5286..620017e3309 100644
--- a/xlators/features/changetimerecorder/src/Makefile.am
+++ b/xlators/features/changetimerecorder/src/Makefile.am
@@ -7,17 +7,19 @@ endif
changetimerecorder_la_LDFLAGS = -module $(GF_XLATOR_DEFAULT_LDFLAGS)
-changetimerecorder_la_SOURCES = changetimerecorder.c ctr-helper.c ctr-xlator-ctx.c
+changetimerecorder_la_SOURCES = changetimerecorder.c \
+ ctr-helper.c ctr-xlator-ctx.c
changetimerecorder_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la\
- $(top_builddir)/libglusterfs/src/gfdb/libgfdb.la
+ $(top_builddir)/libglusterfs/src/gfdb/libgfdb.la
noinst_HEADERS = ctr-messages.h changetimerecorder.h ctr_mem_types.h \
ctr-helper.h ctr-xlator-ctx.h
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
- -I$(top_srcdir)/libglusterfs/src/gfdb \
- -DDATADIR=\"$(localstatedir)\"
+ -I$(top_srcdir)/libglusterfs/src/gfdb \
+ -I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src \
+ -DDATADIR=\"$(localstatedir)\"
AM_CFLAGS = -Wall $(GF_CFLAGS) $(SQLITE_CFLAGS)