summaryrefslogtreecommitdiffstats
path: root/xlators/performance/io-threads/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/performance/io-threads/src/Makefile.am')
-rw-r--r--xlators/performance/io-threads/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/xlators/performance/io-threads/src/Makefile.am b/xlators/performance/io-threads/src/Makefile.am
index bdbd0290fd6..5f5118b4e0f 100644
--- a/xlators/performance/io-threads/src/Makefile.am
+++ b/xlators/performance/io-threads/src/Makefile.am
@@ -1,12 +1,12 @@
xlator_LTLIBRARIES = io-threads.la
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/performance
-io_threads_la_LDFLAGS = -module -avoid-version
+io_threads_la_LDFLAGS = -module $(GF_XLATOR_DEFAULT_LDFLAGS)
io_threads_la_SOURCES = io-threads.c
io_threads_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
-noinst_HEADERS = io-threads.h iot-mem-types.h
+noinst_HEADERS = io-threads.h iot-mem-types.h io-threads-messages.h
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
-DGLUSTERD_WORKDIR=$(GLUSTERD_WORKDIR)