summaryrefslogtreecommitdiffstats
path: root/glustolibs-misc/setup.py
diff options
context:
space:
mode:
authorValerii Ponomarov <vponomar@redhat.com>2019-11-28 22:09:29 +0530
committerBala Konda Reddy M <bmekala@redhat.com>2019-12-09 06:51:03 +0000
commit0f062a2e39b9f9b2dfd6855e8e808bf548d95bb1 (patch)
treeaaf21ab1d897d463a4d35e09e0a0bd7761c80a2e /glustolibs-misc/setup.py
parent2e30b341345ed21015d5b239ce469bf08871766b (diff)
[py2to3] Fix files in the 'glustolibs-misc' directory
Do following updates: - Use 'list' object type in comparisons instead of 'str'. Because it is differently treated in py2 and py3. Example: # In py2 isinstance(u'foo', str) is False # In py3 isinstance(u'foo', str) is True - Add comma separators in the setup.py for it's classifiers. Before it was mistakenly made as one long line. - Fix pep8 errors. - Place 'misc_libs.py' module's imports in alphabetical order. - Update bunch of docstrings of 'misc_libs.py' module's functions to make them look similar. Change-Id: I2ea2d70746c49c9130a31fb97dec76ad38a50f62 Signed-off-by: Valerii Ponomarov <kiparis.kh@gmail.com>
Diffstat (limited to 'glustolibs-misc/setup.py')
-rw-r--r--glustolibs-misc/setup.py30
1 files changed, 17 insertions, 13 deletions
diff --git a/glustolibs-misc/setup.py b/glustolibs-misc/setup.py
index e515d1273..b72b47df0 100644
--- a/glustolibs-misc/setup.py
+++ b/glustolibs-misc/setup.py
@@ -1,5 +1,5 @@
-#!/usr/bin/python
-# Copyright (c) 2016 Red Hat, Inc.
+#!/usr/bin/env python
+# Copyright (c) 2016-2019 Red Hat, Inc.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -31,18 +31,22 @@ setup(
url='http://www.gluster.org',
packages=find_packages(),
classifiers=[
- 'Development Status :: 4 - Beta'
- 'Environment :: Console'
- 'Intended Audience :: Developers'
- 'License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)'
- 'Operating System :: POSIX :: Linux'
- 'Programming Language :: Python'
- 'Programming Language :: Python :: 2'
- 'Programming Language :: Python :: 2.6'
- 'Programming Language :: Python :: 2.7'
- 'Topic :: Software Development :: Testing'
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License v2 or '
+ 'later (GPLv2+)',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Topic :: Software Development :: Testing',
],
install_requires=['glusto'],
- dependency_links=['http://github.com/loadtheaccumulator/glusto/tarball/master#egg=glusto'],
+ dependency_links=[
+ 'http://github.com/loadtheaccumulator/glusto/tarball/master#egg=glusto'
+ ],
namespace_packages = ['glustolibs']
)