summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPrashanth Pai <ppai@redhat.com>2016-08-10 15:28:48 +0530
committerPrashanth Pai <ppai@redhat.com>2016-08-10 18:20:57 +0530
commit655b0d2793386d2059b9c682e931035a83619917 (patch)
treec1dfcc19202af123b649767c6a0bb5c4b340bd63 /setup.py
parentd4b8804abb876bda9803cee61c6c4298b475e6be (diff)
Move source files into gfapi/ dir
Currently, many source files are directly placed under gluster/ dir: gluster/exceptions.py gluster/gfapi.py gluster/utils.py When multiple packages (RPMs) are sharing the same gluster namespace, these source files will conflict if there are source files with same names provided by other projects. Fix: Move all source files in gluster/* to gluster/gfapi/* Note that this patch does not break how existing users import gfapi. Change-Id: Idf9d07eefafe8333215d6c61201c97c982565ba9 Signed-off-by: Prashanth Pai <ppai@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 912959b..26871d7 100644
--- a/setup.py
+++ b/setup.py
@@ -12,11 +12,12 @@
import os
import re
-from setuptools import setup
+from setuptools import setup, find_packages
# Get version without importing.
-gfapi_file_path = os.path.join(os.path.dirname(__file__), 'gluster/gfapi.py')
+gfapi_file_path = os.path.join(os.path.dirname(__file__),
+ 'gluster/gfapi/__init__.py')
with open(gfapi_file_path) as f:
for line in f:
match = re.match(r"__version__.*'([0-9.]+)'", line)
@@ -36,7 +37,7 @@ setup(
author='Red Hat, Inc.',
author_email='gluster-devel@gluster.org',
url='http://www.gluster.org',
- packages=['gluster', ],
+ packages=find_packages(exclude=['test*']),
test_suite='nose.collector',
classifiers=[
'Development Status :: 5 - Production/Stable'