summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPrashanth Pai <ppai@redhat.com>2014-04-10 16:49:05 +0530
committerGerrit Code Review <review@dev.gluster.org>2014-05-19 18:34:48 -0700
commit8acb5a7585a8e155cf0c9d0a60d76e75cdd725f7 (patch)
tree45ffd1ca45cce932b2916a71d94e150fe770db08 /setup.py
parentda5a33d206431f885a4dc029d79f693a27ef293a (diff)
Fix functional tests
* The order of elements in list returned by listdir() can vary and may not be sorted. This caused assertEqual in "test_listdir" to fail. * Also, some systems may have xattrs belonging to selinux. So, a listxattr can list them too. * Allow hostname/ip and volume name to be configured easily by setting it in test.conf. This enables functional tests to use a non-local volume. * Cleanup volume before and after running functional tests. * Added MANIFEST.in and LICENSE file Change-Id: Icfa6eb60e8d8e7ed4d6ab8190a2a2c80688999a3 Signed-off-by: Prashanth Pai <ppai@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index a098896..080a7f4 100644
--- a/setup.py
+++ b/setup.py
@@ -14,7 +14,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-from setuptools import setup, find_packages
+from setuptools import setup
from glusterfs import __canonical_version__ as version
@@ -30,7 +30,7 @@ setup(
author='Red Hat, Inc.',
author_email='gluster-users@gluster.org',
url='http://www.gluster.org',
- packages=find_packages(exclude=['test']),
+ packages=['glusterfs', ],
test_suite='nose.collector',
classifiers=[
'Development Status :: 5 - Production/Stable'