summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPrashanth Pai <ppai@redhat.com>2016-08-16 16:49:50 +0530
committerPrashanth Pai <ppai@redhat.com>2016-08-16 16:49:50 +0530
commitd9d3ee09043184110a0a1a2fcb3db7468e840f82 (patch)
tree17d9943373b9d2515198c655df510d845b2fe60a /setup.py
parentd46e4716fcfc5eefe9b3020e33c570d895203d14 (diff)
Convert README.md to README.rst
Change-Id: Ib89be30f76b5a54addf8a60fee951d3a108bd014 Signed-off-by: Prashanth Pai <ppai@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 90df5a2..b1645ea 100644
--- a/setup.py
+++ b/setup.py
@@ -28,11 +28,15 @@ with open(gfapi_file_path) as f:
raise Exception("Couldn't find version in setup.py")
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+
setup(
name='gfapi',
version=version,
description='Python bindings for GlusterFS libgfapi',
- long_description='Python bindings for GlusterFS libgfapi',
+ long_description=read('README.rst'),
license='GPLv2 or LGPLv3+',
author='Red Hat, Inc.',
author_email='gluster-devel@gluster.org',