summaryrefslogtreecommitdiffstats
path: root/config/Makefile.am
diff options
context:
space:
mode:
authorNishanth Thomas <nthomas@redhat.com>2014-04-08 20:12:14 +0530
committerBala.FA <barumuga@redhat.com>2014-04-29 10:21:37 +0530
commitb40621bc3f1253adaa154428ddef758638b5d175 (patch)
tree9232b9b080ded9d4d2aeb37cec1c2a7ce24a8127 /config/Makefile.am
parent644a9617c9d31a76c0b217950d53355d14b54daf (diff)
SNMP Trap Support : SNMP notification on status change
These plugins will generate SNMP traps when there is a host or service state change in Nagios. Plugged into the Nagios Notification mechanism and uses netsnmp utils to generate SNMP traps Addressed the review comments Change-Id: I42c4d1968a48bc80e767f6fbc24d1637a92d21b0 Signed-off-by: Nishanth Thomas <nthomas@redhat.com>
Diffstat (limited to 'config/Makefile.am')
-rw-r--r--config/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/config/Makefile.am b/config/Makefile.am
index 0f7f73a..4435879 100644
--- a/config/Makefile.am
+++ b/config/Makefile.am
@@ -6,6 +6,7 @@ glusternagiosconf_DATA = \
gluster-templates.cfg \
gluster-contacts.cfg \
host-monitoring-services.in \
+ snmpmanagers.cfg \
$(NULL)
glusternagiosdefaultconfdir = $(sysconfdir)/nagios/gluster/default
@@ -15,7 +16,14 @@ glusternagiosdefaultconf_DATA = \
node1.cfg \
$(NULL)
+glusternagiosmibsdir = /usr/share/snmp/mibs
+glusternagiosmibs_DATA = \
+ NAGIOS-NOTIFY-MIB \
+ NAGIOS-ROOT-MIB \
+ $(NULL)
+
EXTRA_DIST = \
$(glusternagiosconf_DATA) \
$(glusternagiosdefaultconf_DATA) \
+ $(glusternagiosmibs_DATA) \
$(NULL)