summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorShubhendu Tripathi <shtripat@redhat.com>2014-03-21 13:53:46 +0530
committerBala.FA <barumuga@redhat.com>2014-04-29 10:21:37 +0530
commit26b98e7239222704bb7438bcc47793fc6be60f2c (patch)
treeb2f62a1188a44cd5337c711e1d8b5a04b98e3b90 /configure.ac
parent81cc690fbe74f15e73c30079ea4bff1c37fefa3f (diff)
nagios-server-addons: Test case for host event handler
Added unit test cases for host event handler with minor code fixes Change-Id: Id9516303aaa1e4f14e781a06d4f73158bfcdebf4 Signed-off-by: Shubhendu Tripathi <shtripat@redhat.com> Reviewed-on: https://code.engineering.redhat.com/gerrit/21669 Reviewed-by: Darshan Narayana Murthy <dnarayan@redhat.com> Reviewed-by: Sahina Bose <sabose@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 661dfd9..e9067e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,8 @@ AC_SUBST([glusternagiospluginsdir], ['${nagiospluginsdir}/gluster'])
AC_SUBST([glusternagioscommonpylibdir], ['${pyexecdir}/glusternagios'])
AC_SUBST([nagiosserveraddonstestsdir], ['${datarootdir}/${PACKAGE_NAME}/tests'])
AC_SUBST([nagioslivestatussocketpath], ['/var/spool/nagios/cmd/live'])
+AC_SUBST([nagioscommandfilepath], ['/var/spool/nagios/cmd/nagios.cmd'])
+AC_SUBST([hostmonitoringserviceslist], ['/etc/nagios/gluster/host-monitoring-services.in'])
# Checking for pyflakes
AC_PATH_PROG([PYFLAKES], [pyflakes])
@@ -94,7 +96,9 @@ AC_CONFIG_FILES([
Makefile
nagios-server-addons.spec
config/Makefile
+ plugins/check_remote_host.py
plugins/constants.py
+ plugins/gluster_host_service_handler.py
plugins/Makefile
templates/Makefile
tests/Makefile